Update Your Browser – The updateyourbrowser.net campaign

[Que tal uma versão em português deste texto?]

If you are an web developer you know how much is annoying and laboured to make cross-browser websites. The first reason to all this frustation is the quantity of users still using Microsoft’s Internet Explorer 6, an old and very outdated web browser, with security issues and none of the new web development standards.

uyb

My idea was get all this users to update their browsers at least to the Internet Explorer 7 version. Of course I’m not interested in defend any of these browsers, I just want a better develop enviroment to us all.

Inspired by the savethedevelopers.org work, I created the update your browser website. It provides an piece of a JavaScript code that you put on your website’s HEAD and warn all your users when they are using outdated browsers like the Internet Explorer 6.

I’m so grateful for all the world developers support on this little movement.

[update fev/2013] Opera issues were fixed.

Link to the english version of Update Your Browser: http://www.updateyourbrowser.net/en/

Quer mais code & design? Siga-me no Twitter @richardbarros

11 comentá em “Update Your Browser – The updateyourbrowser.net campaign

  1. EvilTroopa 07/03/2010 11:35

    Hi !
    I’m starting my own website company and was looking for this kind of site.
    I’ve got into this one after googling “why update your browser” and I think it would be great to have it in much more languages.
    I could do the french translation if you want me to, so I could make a link to it on my future website.
    Hope to read from you soon !

    Responder

    Richard Reply:

    You can help us to translate to any language, just send me an email through the contact page of this site :)

  2. ZAP 07/05/2010 17:43

    Great script, but it’s broken lately. I get an Uncaught SyntaxError: Unexpected token ILLEGAL error and the script does not run (or unpack in order to debug it). I noticed that your site was down for a few days also – hope the script wasn’t hacked!

    Responder

  3. claes lund 31/10/2011 15:31

    I use IE8 browser and your site tells me to update my browser??? What to do?? Is that one really so outdasted??

    Responder

  4. erik 12/03/2012 14:24

    Hey son of the bitch, i have the right browser and everytime that i go in certain pages i get a fucking message that i have the wrong browser MOTHER FUCKERS because it is not true !!!! Sudacas mother fuckewrs

    Responder

    Richard Reply:

    Its an resolved issue. Sorry about that.

  5. erik 12/03/2012 14:27

    This messages are the idea of a fucking sudaca called Richard…this mother fucker should go to school because he in an annoying son of the bitch !!!

    Responder

  6. erik 12/03/2012 14:28

    Hey Richard mother fucker !!!! I have IE 8 so the right browser

    Responder

  7. Charlie Ruelle 06/08/2012 09:32

    This is a Really good blog and it is very informative.. Thank you so much for your time in writing this stuff. I will put some links to some of those articles on my Facebook page for my friends to come and read it as well.Thank you.

    Responder

Faça um comentário

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>